Multiple bugs about settings and watchOS

#1

Hi,

First of all I love the app, I have been looking for a replacement to my previous habit tracker (Streaks) for a while now and finally stumbled upon this one and so far I love it :slight_smile:

First bug, start of day time not being adhered to:
In my settings on Habitify I’ve set it so the start of day (morning) starts at 06:00, but my habits for the next day gets shown when we pass midnight, instead of at 6 o’ clock where they should start appearing. I’m assuming this is NOT intended because why else would you have the setting for start of day :thinking:.
This was a feature I used a lot when using my old habit tracker

watchOS app only shows morning and all habits menus
For some reason the watchOS app only shows ‘morning’ and ‘all habits’ menu, no matter the time of day. This is really confusing because the images you show on the App Store shows a slider with ‘current day period’ (e.g. afternoon) or ‘all habits’. I don’t have these, instead I just have the two menus I talked about at the start, all out through the day! :frowning:
An extra for this: Some times my ‘all habits’ says 0 even though none of the habits have been completed.

2 lesser ones

  1. Is it intentional I still get notifications for habits I’ve already completed for the day?
  2. I tried using the Face ID feature, but it bugs a lot and sometimes it just outright doesn’t work (need to use passcode), so I disabled it for now.

Hardware used:
iPhone 11 Pro Max
AW Series 4
Both running newest iOS/watchOS

What I’ve tried:

  • Reinstalling the apps multiple times (both on watch and phone)
  • Reinstalled my phone and watch from scratch (only did this because I had problems with other apps)

Thanks,
Robert

P.S. Hope you get through all of it, because it’s perhaps a bit much at once haha

1 Like
Habitify doesn't notify you, when the task is done sooner than expected
#2

@AlanNg Has anyone taken a look at this yet :smile:?

1 Like
#3

Hi Robert, thanks a lot for your detailed report and really apologize for getting back this late. Let’s walk through each problem:

  1. Time of Day: Yes it is a known bug and Peter is fixing it at the moment. The main cause of this is a mismatch between the current feature that lets you set the time and the system time.

  2. WatchOS app: We have fixed it already on 6.2.2. Do you still have it?
    We calculate and process all your data in the phone, so the only way to transfer them to your watch is to open the phone app at least once a day (and of course, connect it to the watch). That way you’ll be able to prevent the “0 habit” problem.

  3. Notifications for habits you’ve already completed: This I have addressed in another post where you are present :slight_smile: Technically it can be the fact that you didn’t leave your phone connected to the internet so your completion is not “recognized” by the server.

  4. FaceID: I really hope to know more context around this. When exactly is sometimes? Can you describe a bit?

#4

Hi Alan, Thanks for the answer! :smiley:

  1. I’m really looking forward to that update, it’ll remove a lot of hassle :smile:

  2. Yeah, the bug with 0 habits seems to be gone, but the whole thing with the menu only showing ‘morning’ menu all times of the day and not ‘afternoon’ or ‘evening’ is still there :frowning_face:

  3. Hmmm, this one I would have to report in on in a couple of days, haven’t noticed any problems lately though.

  4. I’ve tried re-enabling FaceID again now and it seems like the problems I had last time were just a fluke!

#5

Spoke too soon about the FaceID problem, it’s still there and it happens when the app has been in the background for a while, then when I open it, no buttons work on the ‘passcode’ screen and neither is there a faceID pop up :frowning:, if I then reopen the app I’m allowed to type in the passcode, and then if I reopen it for a third time, FaceID will be working again

#6

Hi Robert!

  1. Can you also chat with us within Habitify so we can have your user ID to investigate further? It will help accelerate the fix!

  2. Aww too bad. No worries we’re right on it!

  3. Yeah waiting for you!

  4. Definitely a bug caused by iOS 13. I will check this with Peter. No worries!

1 Like